Archie Comics Fan Forum

Board Info => Announcements => Topic started by: Oldiesmann on May 15, 2017, 12:33:05 AM

Title: New: enhanced site security
Post by: Oldiesmann on May 15, 2017, 12:33:05 AM
Just a quick note for everyone. With the latest update to the forum software, I have switched the site over to use https (secure) URLs instead of plain http. You shouldn't notice much difference (though you'll now see a green lock and "Secure" next to the URL in Google Chrome and similar things in other browsers), but this will enhance security, especially where usernames and passwords are concerned. If you have any questions or run into any problems, let me know.
Title: Re: New: enhanced site security
Post by: SAGG on May 15, 2017, 09:24:10 AM
Thank you...  :)
Title: Re: New: enhanced site security
Post by: DeCarlo Rules on May 18, 2017, 07:35:08 AM
There seems to be a problem with editing posts. When I try, I get a message saying the information is being sent over an unsecure connection, and the edit fails.
Title: Re: New: enhanced site security
Post by: DeCarlo Rules on May 19, 2017, 02:18:51 AM
The search function isn't working either. It just opens a new (blank screen) tab when trying to search.
Title: Re: New: enhanced site security
Post by: Oldiesmann on May 27, 2017, 11:12:45 AM
Thanks for the reports. I'll take a look and see what I can do.
Title: Re: New: enhanced site security
Post by: Oldiesmann on May 27, 2017, 12:45:56 PM
Search has been fixed. That was due to a bug with the latest version of the forum software. I'm still looking into the post modification issues.
Title: Re: New: enhanced site security
Post by: DeCarlo Rules on May 28, 2017, 05:59:49 AM
Search has been fixed. That was due to a bug with the latest version of the forum software. I'm still looking into the post modification issues.

It's even worse than that now. Not only does the "Modify" button not work, but the "REPLY" doesn't work at all, and returns a dialogue box saying "Security Warning: The information you have entered on this page will be sent over an insecure connection and could be read by a third party.  Are you sure you want to send this information?"  Choosing "Continue" or "Cancel" in the Security Warning dialogue box is irrelevant, as the text I typed will not be posted. Instead, I'm returned to the Forum topics listing page. Or at least that's how it's working in both Firefox and Chrome browsers.

Fortunately the "Quick Reply" button does still seem to work, otherwise it would be impossible for me to post at all.
Title: Re: New: enhanced site security
Post by: steveinthecity on May 28, 2017, 06:39:37 AM
Same on my end.   Same browsers
Title: Re: New: enhanced site security
Post by: Oldiesmann on May 28, 2017, 08:53:47 AM
I'm not sure what's going on with that and will look into it later today when I have more time
Title: Re: New: enhanced site security
Post by: Oldiesmann on May 28, 2017, 03:02:25 PM
Just in case anyone didn't see my reply to the other topic about the issues, everything should be fixed now. The post form being broken was due to a server setting that was somehow messing up the URLs, and the security error was due to a hidden setting related to the addon that rewrites the URLs.
Title: Re: New: enhanced site security
Post by: SAGG on May 28, 2017, 06:20:15 PM

Just in case anyone didn't see my reply to the other topic about the issues, everything should be fixed now. The post form being broken was due to a server setting that was somehow messing up the URLs, and the security error was due to a hidden setting related to the addon that rewrites the URLs.


Got a new problem for you, sorry. You know in the albums where you have "newer" or "older" at the bottom of a page panel where you can go to the next or previous page panel? Well, some pages have them, and others don't. One has to go back to an album page with the 24 panels, then click on a panel, as opposed to clicking through the pages...